nvidia



2 cose che mi stanno qui e Fedora 9

| |


Il client di posta Evolution firma le email come allegato, mentre Thunderbird le firma nel testo, il risultato è questo.


Ubuntu chiede di riavviare il computer perché ha installato i driver proprietari nvidia, perché ciò? Basta terminare la sessione dell'utente e rientrare, o al max ctrl+alt+backspace(<-)

Per chiudere in bellezza è uscita Fedora 9 con qualche funzionalità interessante:

- Package Kit: un sistema omogeneo che non sostituisce deb/rpm/tgz, ma almeno offre una GUI condivisa per installare programmi. Inoltre, suggerisce quali programmi installare per aprire un certo tipo di file
- Policy Kit: un framework per gestire solo alcune azioni come root, ma lo avevate capito che "sudo" è un hack?
- LiveUSB Persistente: un sistema operativo disponibile in lettura e scrittura sempre disponibile su chiavetta USB

In conclusione, provatelo o aspettate la prossima versione di Ubuntu, 8.10 Intrepid Ibex.

Scusate, se non uso toni sensazionalistici è che in questo periodo sono un po' apatico nei confronti della tecnologia.


SCHIFOSISSIMO BUG NVIDIA con Totem e OGG

| |

Aggiornamento: Risolto installando il .run ufficialle NVIDIA. Il kernel non si blocca più, ma comunque il video non si vede con Totem (malgrado sia OGG). probabilmente Totem non lo riconosce bene e dice che è da 2000Kb/s.
Riguardo NVIDIA, ho dovuto PROPRIO installare il .run del 1.0-9639 perchè non era disponibile nessun deb ne su Gutsy ne tramite Envy.

Ho provato un po' di kernel e driver NVIDIA, ma il problema rimane lo stesso. Alcuni file ogg (es alcuni di MacSlow) aperti con Totem frezzano X al punto tale che non è neppure possibile riavviarlo in remoto(ssh), bisogna proprio riaviare il PC.

Questo è il dmesg, preso da ssh:

[ 86.788000] **WARNING** I2C adapter driver [NVIDIA i2c adapter 0 at 1:00.0] forgot to specify physical device; fix it!
[ 86.788000] **WARNING** I2C adapter driver [NVIDIA i2c adapter 1 at 1:00.0] forgot to specify physical device; fix it!
[ 86.792000] **WARNING** I2C adapter driver [NVIDIA i2c adapter 2 at 1:00.0] forgot to specify physical device; fix it!
...
[ 903.540000] NVRM: Xid (0001:00): 13, 0000 01019700 00001796 00000240 019b013e 00000002
[ 903.568000] NVRM: Xid (0001:00): 13, 0000 01019700 00001796 00000240 019b013e 00000002
[ 903.572000] BUG: unable to handle kernel NULL pointer dereference at virtual address 00000080
[ 903.572000] printing eip:
[ 903.572000] f9346057
[ 903.572000] *pde = 00000000
[ 903.572000] Oops: 0000 [#1]
[ 903.572000] Modules linked in: ipt_TCPMSS xt_limit xt_tcpudp nf_nat_irc nf_nat_ftp iptable_nat iptable_mangle ipt_LOG ipt_MASQUERADE nf_nat ipt_TOS ipt_REJECT nf_conntrack_irc nf_conntrack_ftp nf_conntrack_ipv4 xt_state nf_conntrack nfnetlink iptable_filter ip_tables x_tables ppp_deflate zlib_deflate bsd_comp pppoatm binfmt_misc rfcomm l2cap vmnet(P) vmmon(P) ext2 ext3 jbd mbcache nls_iso8859_1 nls_cp437 vfat fat fuse w83781d hwmon_vid i2c_isa sr_mod sbp2 lp sg speedtch usbatm sd_mod hci_usb bluetooth nvidia(P) parport_pc parport rtc snd_emu10k1_synth snd_emux_synth snd_seq_virmidi snd_seq_midi_emul snd_emu10k1 snd_ac97_codec pcspkr ac97_bus snd_pcm_oss psmouse serio_raw snd_mixer_oss snd_pcm snd_page_alloc snd_util_mem snd_hwdep snd_seq_dummy i2c_viapro via_ircc snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event irda i2c_core snd_seq snd_timer snd_seq_device via_agp agpgart snd shpchp pci_hotplug soundcore emu10k1_gp gameport tsdev evdev ppp_async ppp_generic slhc crc_ccitt reiserfs ide_cd cdrom ide_disk generic usb_storage libusual via82cxxx 8139cp ata_generic libata scsi_mod 8139too mii ohci1394 ieee1394 ehci_hcd uhci_hcd usbcore thermal processor fan fbcon tileblit font bitblit softcursor vesafb capability commoncap
[ 903.572000] CPU: 0
[ 903.572000] EIP: 0060:[] Tainted: P VLI
[ 903.572000] EFLAGS: 00213297 (2.6.20-15-386 #2)
[ 903.572000] EIP is at _nv008760rm+0xf/0x20 [nvidia]
[ 903.572000] eax: 00000000 ebx: f6041000 ecx: f69b8000 edx: f69b8000
[ 903.572000] esi: f7569a30 edi: f7569a40 ebp: f75699c4 esp: f75699b4
[ 903.572000] ds: 007b es: 007b ss: 0068
[ 903.572000] Process Xorg (pid: 13509, ti=f7568000 task=c1beca90 task.ti=f7568000)
[ 903.572000] Stack: 000000a6 000000a1 00000a00 00000010 f7569ac8 f938eb58 f69b8000 00000000
[ 903.572000] 00000009 00000000 000000ff 00000001 f7569b60 f6041000 f6041000 00400720
[ 903.572000] 00000001 f6041000 f6995000 f6995800 f69d5000 f63a3400 f765b400 f6041000
[ 903.572000] Call Trace:
[ 903.572000] [] _nv003367rm+0x908/0x9e8 [nvidia]
[ 903.572000] [] _nv002939rm+0x2b/0x84 [nvidia]
[ 903.572000] [] _nv002933rm+0x1d/0x2c [nvidia]
[ 903.572000] [] _nv002933rm+0x26/0x2c [nvidia]
[ 903.572000] [] _nv008763rm+0x52/0x70 [nvidia]
[ 903.572000] [] _nv005892rm+0x23/0x28 [nvidia]
[ 903.572000] [] _nv008764rm+0x32/0xa0 [nvidia]
[ 903.572000] [] _nv008764rm+0x5a/0xa0 [nvidia]
[ 903.572000] [] _nv007574rm+0x3e/0x17c [nvidia]
[ 903.572000] [] _nv003375rm+0x1c6/0x1168 [nvidia]
[ 903.572000] [] _nv003375rm+0x2c2/0x1168 [nvidia]
[ 903.572000] [] _nv005892rm+0x23/0x28 [nvidia]
[ 903.572000] [] _nv002933rm+0x26/0x2c [nvidia]
[ 903.572000] [] _nv002933rm+0x1d/0x2c [nvidia]
[ 903.572000] [] _nv002933rm+0x26/0x2c [nvidia]
[ 903.572000] [] _nv002933rm+0x26/0x2c [nvidia]
[ 903.572000] [] _nv002933rm+0x1d/0x2c [nvidia]
[ 903.572000] [] _nv002933rm+0x26/0x2c [nvidia]
[ 903.572000] [] _nv005896rm+0x25/0x44 [nvidia]
[ 903.572000] [] _nv005892rm+0x23/0x28 [nvidia]
[ 903.572000] [] _nv000382rm+0x1e2/0x324 [nvidia]
[ 903.572000] [] _nv000382rm+0x1bd/0x324 [nvidia]
[ 903.572000] [] _nv005584rm+0x73/0xb8 [nvidia]
[ 903.572000] [] _nv005584rm+0xaa/0xb8 [nvidia]
[ 903.572000] [] _nv006581rm+0x9a/0xfc [nvidia]
[ 903.572000] [] _nv006579rm+0x2c/0x44 [nvidia]
[ 903.572000] [] _nv006579rm+0x39/0x44 [nvidia]
[ 903.572000] [] _nv005646rm+0xf1/0xfc [nvidia]
[ 903.572000] [] _nv006557rm+0x4f/0x13c [nvidia]
[ 903.572000] [] _nv006557rm+0xa6/0x13c [nvidia]
[ 903.572000] [] _nv009861rm+0x13/0x38 [nvidia]
[ 903.572000] [] _nv006465rm+0xab/0xc0 [nvidia]
[ 903.572000] [] _nv009861rm+0x13/0x38 [nvidia]
[ 903.572000] [] _nv006585rm+0x1f/0x28 [nvidia]
[ 903.572000] [] _nv009861rm+0x13/0x38 [nvidia]
[ 903.572000] [] _nv009864rm+0x1f/0x130 [nvidia]
[ 903.572000] [] _nv009828rm+0x16/0x34 [nvidia]
[ 903.572000] [] _nv009864rm+0x1f/0x130 [nvidia]
[ 903.572000] [] _nv001952rm+0x32/0x244 [nvidia]
[ 903.572000] [] _nv009886rm+0x4f/0xd4 [nvidia]
[ 903.572000] [] _nv002043rm+0x3d0/0x400 [nvidia]
[ 903.572000] [] _nv002043rm+0x3aa/0x400 [nvidia]
[ 903.572000] [] _nv005646rm+0xf1/0xfc [nvidia]
[ 903.572000] [] _nv009858rm+0x23/0x6c [nvidia]
[ 903.572000] [] _nv002044rm+0xd1/0x258 [nvidia]
[ 903.572000] [] _nv002769rm+0x12/0x18 [nvidia]
[ 903.572000] [] _nv003646rm+0x33/0x9c [nvidia]
[ 903.572000] [] _nv003646rm+0x69/0x9c [nvidia]
[ 903.572000] [] rm_set_interrupts+0x142/0x15c [nvidia]
[ 903.572000] [] _nv001996rm+0x3d/0x770 [nvidia]
[ 903.572000] [] _nv001996rm+0x1d3/0x770 [nvidia]
[ 903.572000] [] _nv002658rm+0x12/0x1c [nvidia]
[ 903.572000] [] _nv002769rm+0x12/0x18 [nvidia]
[ 903.572000] [] kmap_atomic+0x77/0x90
[ 903.572000] [] rm_ioctl+0x1c/0x24 [nvidia]
[ 903.572000] [] prio_tree_remove+0x63/0xc0
[ 903.572000] [] copy_from_user+0x27/0x60
[ 903.572000] [] nv_kern_ioctl+0x2f9/0x36a [nvidia]
[ 903.572000] [] nv_kern_unlocked_ioctl+0x18/0x1d [nvidia]
[ 903.572000] [] nv_kern_unlocked_ioctl+0x0/0x1d [nvidia]
[ 903.572000] [] do_ioctl+0x1f/0x70
[ 903.572000] [] do_munmap+0x186/0x1e0
[ 903.572000] [] vfs_ioctl+0x5c/0x270
[ 903.572000] [] sys_ioctl+0x72/0x90
[ 903.572000] [] syscall_call+0x7/0xb
[ 903.572000] [] show_stack_log_lvl+0x29/0xe0
[ 903.572000] =======================
[ 903.572000] Code: 14 50 6a 03 8b 45 10 50 51 53 8b 42 14 ff d0 90 8d 74 26 00 8b 5d e8 89 ec 5d c3 90 55 89 e5 83 ec 08 8b 4d 08 8b 45 0c 83 c4 f8 <8b> 90 80 00 00 00 50 51 8b 42 04 ff d0 89 ec 5d c3 55 89 e5 8b
[ 903.572000] EIP: [] _nv008760rm+0xf/0x20 [nvidia] SS:ESP 0068:f75699b4

capita a qualcun'altro? Siete riusciti a risolverlo?Aggiornamento: Il bug deve essere per forza in nvidia 1.0-9631, anche perché con totem e driver OS non succede. Il fatto che con MPlayer non succede è probabilmente perché usa qualche altro backend.


Finalmente mi funziona NVIDIA su Ubuntu Feisty!

| |

Non sarà una gran notizia, ma finalmente funziona anche a me il driver nvidia su Feisty!!!
Ho provato di tutto, anche a compilarmi i driver proprietari dal sito nvidia, ma niente sempre il solito errore molto informativo.. segfault, ogni volta che provavo ad avviare X con le GLX abilitate.

Adesso con questi pacchetti installati va tutto bene.

nvidia-glx 1.0.9631+2.6.20.3-11.10
nvidia-kernel-common 20051028+1ubuntu7
linux-image-2.6.20-10-386 2.6.20-10.17
linux-restricted-modules-2.6.20-10-386 2.6.20.3-10.9

Mi era venuto anche il dubbio che la mia GeForce4 fosse andata in nvidia-glx-legacy, fortunatamente non è stato così e finalmente adesso posso continuare a divertirmi con Compiz, Awn e Google Earth.


Syndicate content